Supported Browsers

​Compatible browsers

To ensure the highest level of security and optimise your experience, we recommend you access the platform using the minimum browser versions and operating systems listed below.
 
  • Windows Internet Explorer    9.0, 10.0, 11.0
  • Mozilla Firefox    35, 36
  • Google Chrome 39, 40
  • Apple Safari    8.0

The internet browser requirements will determine hardware, memory and operating system, such as:
 
  • Microsoft  Windows Vista, Windows 7, Windows 8.x, Windows 10
  • Apple Mac
  • Scripting (Java script) must be enabled
  • Cookies must be enabled.

Connectivity requirements are:
  • Connection to the Internet via an Internet Service Provider.
  • Ability to connect to https:\\sites.

App

The App is compatible with the following:
 
  • iOS    7.0 and above    
  • Android    4.0 and above
  • Windows Phone 10.0 and above

Did you find this article helpful?